Keg liner & adapter attachment issues

#1
Second brew here and this time thought on kegging rather than bottling. Received my keg kit today, sanitised it and when trying to put the adapter on the liner it just won't screw on. Even after applying some pressure, it sits really wonky. Anybody else had this issue? Maybe a bad batch of adapters or liners? Tried on 4 different liners, all having the same issue.

Also, if I already changed my beerdroid from storage mode to kegging mode, is there any issues with setting it back to storage mode? In case I don't get it sorted today?

Thanks guys.
 

Doug

BrewArt Rookie
#2
Hi mate
Yep got the same problem as well.
Different thread by the look of it.
We have been able to screw them on but it's a battle.
Then watched one of the videos that said don't hold and crush the liner as it causes heady beers.
Emailing brewart about it.
I'll update you once they come back to me.
Not sure about the settings
Good luck
Cheers
 
#3
Been on the line with Liam from BA, and apparently you need to firmly push down on the screw cap and twist at the same time. It worked for me, but need to be careful not to break the liner.
 
#4
This what I got back from BA:

"
Hi Sabi,
I have had a lot of experience with these threads, and have found the best method when threading the Keg Liner to the Keg Liner Connector is:
  • Find the start of each thread and line them up
  • Twist back (anticlockwise) 1mm,
  • Push them together hard while threading clockwise
The Keg Liner has a little lip on it, and by pushing them hard together it jumps the lip, and makes it much easier to thread."

It did work!
 
#5
Mate the pushing it in hard at the start does the trick.
I also have just started holding the liner bag with some multi grips (got to be a bit careful) so you don't touch the keg liner at all when putting the top on. Seams to work alright.
Thx and cheers